第二十八章 DragonFlyBSD
第七节 安装 QQ
介绍
FreeBSD 安装 Linux QQ 方法

安装 Linux 兼容层:

请先安装 Linux 兼容层,具体请看 第五章 第五节。
1
# pkg install linux-c7-gtk2 linux-c7-libxkbcommon
Copied!

下载 Linux QQ

1
# mkdir /home/work
2
# fetch https://down.qq.com/qqweb/LinuxQQ/linuxqq_2.0.0-b2-1089_x86_64.rpm
Copied!
提示:后续如果版本更新请自行前往
手动下载。
安装 Linux QQ:
1
# pkg install archivers/rpm4
2
# cd /compat/linux
3
# rpm2cpio < /home/work/linuxqq_2.0.0-b2-1089_x86_64.rpm | cpio -id
Copied!

下载并安装 Linux QQ 所需依赖

由于未知原因,安装的 Linux QQ 无法输入,需要安装以下依赖才可以输入文字,但是只摸索了 Fcitx 输入法框架下的依赖。
1
# cd /home/work
2
# fetch http://mirror.centos.org/centos/7/os/x86_64/Packages/gtk2-immodule-xim-2.24.31-1.el7.x86_64.rpm
3
# fetch https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/f/fcitx-gtk2-4.2.9.6-1.el7.x86_64.rpm
4
# fetch https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/f/fcitx-4.2.9.6-1.el7.x86_64.rpm
5
# fetch https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/f/fcitx-libs-4.2.9.6-1.el7.x86_64.rpm
Copied!
然后分别安装以上 4 个包:
1
# cd /compat/linux
2
# rpm2cpio < /home/work/gtk2-immodule-xim-2.24.31-1.el7.x86_64.rpm | cpio -id
3
# rpm2cpio < /home/work/fcitx-gtk2-4.2.9.6-1.el7.x86_64.rpm | cpio -id
4
# rpm2cpio < /home/work/fcitx-4.2.9.6-1.el7.x86_64.rpm | cpio -id
5
# rpm2cpio < /home/work/fcitx-libs-4.2.9.6-1.el7.x86_64.rpm | cpio -id
Copied!
注意:为了方便境内 FreeBSD 用户,可以使用境内的 gitee 同步下载以上 4 个文件;
经验与教训:
请远离境内诸如 gitee 等无良企业。
Github:

刷新 gtk 缓存

# /compat/linux/usr/bin/gtk-query-immodules-2.0-64 --update-cache

运行 Linux QQ

$ /compat/linux/usr/local/bin/qq